import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z_]+)[ ]*:=[ ]*'([^']*)';";
final String string = "unit Language.EN;\n\n"
+ "interface\n\n"
+ "uses\n"
+ " Winapi.Windows, System.SysUtils;\n\n"
+ "type\n"
+ " TDummyParent = record\n"
+ " private const\n"
+ " Languages: array [0 .. 2] of string = ('German', 'English');\n"
+ " public\n"
+ " class var a, b, c, d: string;\n"
+ " class procedure DummyProcedure; static;\n"
+ " end;\n\n"
+ "implementation\n\n"
+ "class procedure TDummyParent.DummyProcedure;\n"
+ "begin\n"
+ " a := 'string-a';\n"
+ " b := 'string-b';\n\n"
+ " c := sLineBreak + 'string-d';\n\n"
+ " d :=\n"
+ " '1 2 3 ' +\n"
+ " '4 5 6 ' +\n"
+ " '7 8 9';\n"
+ "end; ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}