using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\n\r].*Owner:\s*\K((?!\\n\\n).)*";
string input = @"{
""description"": ""This project contains the code, pipelines and artifacts for the (ProjectName) project. \nOwner: (OwnerName)\n\nDetails: (ProjectDetails)
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}