const regex = /[\n\r].*Owner:\s*\K((?!\\n\\n).)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\n\\r].*Owner:\\s*\\K((?!\\\\n\\\\n).)*', 'gm')
const str = `{
"description": "This project contains the code, pipelines and artifacts for the (ProjectName) project. \\nOwner: (OwnerName)\\n\\nDetails: (ProjectDetails)
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}