re = /[\n\r].*Owner:\s*\K((?!\\n\\n).)*/m
str = '{
"description": "This project contains the code, pipelines and artifacts for the (ProjectName) project. \\nOwner: (OwnerName)\\n\\nDetails: (ProjectDetails)
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end