import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\n\\r].*Owner:\\s*\\K((?!\\\\n\\\\n).)*";
final String string = "{\n\n"
+ "\"description\": \"This project contains the code, pipelines and artifacts for the (ProjectName) project. \\nOwner: (OwnerName)\\n\\nDetails: (ProjectDetails)\n\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}