#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Dear\s*user\s*(?=\S)(.{1,5}.{1,5}) thanks$"
Local $sString = "Dear user 1 2 thanks" & @CRLF & _
"Dear user 12345 6789 thanks" & @CRLF & _
"Dear user 123 5 6789 thanks" & @CRLF & _
"Dear user 1 thanks" & @CRLF & _
"Dear user1 2 thanks"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")