import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Dear\\s*user\\s*(?=\\S)(.{1,5}.{1,5}) thanks$";
final String string = "Dear user 1 2 thanks\n"
+ "Dear user 12345 6789 thanks\n"
+ "Dear user 123 5 6789 thanks\n"
+ "Dear user 1 thanks\n"
+ "Dear user1 2 thanks";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}