const regex = /^Dear\s*user\s*(?=\S)(.{1,5}.{1,5}) thanks$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Dear\\s*user\\s*(?=\\S)(.{1,5}.{1,5}) thanks$', 'gm')
const str = `Dear user 1 2 thanks
Dear user 12345 6789 thanks
Dear user 123 5 6789 thanks
Dear user 1 thanks
Dear user1 2 thanks`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}