$re = '/^Dear\s*user\s*(?=\S)(.{1,5}.{1,5}) thanks$/m';
$str = 'Dear user 1 2 thanks
Dear user 12345 6789 thanks
Dear user 123 5 6789 thanks
Dear user 1 thanks
Dear user1 2 thanks';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);