import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\S*trash\\S*\\b";
final String string = "\"SVGSVGElement: html > body.template-home.overflow-none > div.theme-w\" + \"ide#container > form.js-ajax-cart-panel.js-fullscreen-modal.ajax-car\" + \"t-container.modal-right.modal-xs.modal-xs-right.modal-xs-right-out#a\" + \"jax-cart-details > div.modal-xs-dialog > div.modal-content > div.aja\" + \"x-cart-body.modal-right-body.modal-xs-body > div.js-ajax-cart-list.a\" + \"jax-cart-table.pull-left > div.js-cart-item.js-cart-item-shippable.a\" + \"jax-cart-item > div.ajax-cart-item-delete-col.cart-delete-container.\" + \"ajax-cart-item-col.text-right > button.cart-btn-delete.ajax-cart-btn\" + \"-delete.pull-right.p-top-none > div.cart-delete-svg-icon.svg-icon-te\" + \"xt > svg.svg-trash-icon\"\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}