# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b\S*trash\S*\b"
test_str = ("\"SVGSVGElement: html > body.template-home.overflow-none > div.theme-w\" + \"ide#container > form.js-ajax-cart-panel.js-fullscreen-modal.ajax-car\" + \"t-container.modal-right.modal-xs.modal-xs-right.modal-xs-right-out#a\" + \"jax-cart-details > div.modal-xs-dialog > div.modal-content > div.aja\" + \"x-cart-body.modal-right-body.modal-xs-body > div.js-ajax-cart-list.a\" + \"jax-cart-table.pull-left > div.js-cart-item.js-cart-item-shippable.a\" + \"jax-cart-item > div.ajax-cart-item-delete-col.cart-delete-container.\" + \"ajax-cart-item-col.text-right > button.cart-btn-delete.ajax-cart-btn\" + \"-delete.pull-right.p-top-none > div.cart-delete-svg-icon.svg-icon-te\" + \"xt > svg.svg-trash-icon\"\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.