// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\S*trash\S*\b").unwrap();
let string = "\"SVGSVGElement: html > body.template-home.overflow-none > div.theme-w\" + \"ide#container > form.js-ajax-cart-panel.js-fullscreen-modal.ajax-car\" + \"t-container.modal-right.modal-xs.modal-xs-right.modal-xs-right-out#a\" + \"jax-cart-details > div.modal-xs-dialog > div.modal-content > div.aja\" + \"x-cart-body.modal-right-body.modal-xs-body > div.js-ajax-cart-list.a\" + \"jax-cart-table.pull-left > div.js-cart-item.js-cart-item-shippable.a\" + \"jax-cart-item > div.ajax-cart-item-delete-col.cart-delete-container.\" + \"ajax-cart-item-col.text-right > button.cart-btn-delete.ajax-cart-btn\" + \"-delete.pull-right.p-top-none > div.cart-delete-svg-icon.svg-icon-te\" + \"xt > svg.svg-trash-icon\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}