import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=SECTION I\\s?.+\\s?\\w*\\s+\\d.*\\s+).+";
final String string = "SECTION I\n"
+ "Request Type Request Date Current Loginid\n"
+ "Deactivate 03/30/21 iamauserid\n"
+ "SECTION II More Stuff\n"
+ "Blah blah\n"
+ "SECTION III Even More Stuff\n"
+ "Blah blah blah\n"
+ "SECTION IV: So much stuff\n"
+ "Blah blah blah";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}