re = /(?<=SECTION I\s?.+\s?\w*\s+\d.*\s+).+/m
str = 'SECTION I
Request Type Request Date Current Loginid
Deactivate 03/30/21 iamauserid
SECTION II More Stuff
Blah blah
SECTION III Even More Stuff
Blah blah blah
SECTION IV: So much stuff
Blah blah blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end