use strict;
my $str = 'SECTION I
Request Type Request Date Current Loginid
Deactivate 03/30/21 iamauserid
SECTION II More Stuff
Blah blah
SECTION III Even More Stuff
Blah blah blah
SECTION IV: So much stuff
Blah blah blah';
my $regex = qr/(?<=SECTION I\s?.+\s?\w*\s+\d.*\s+).+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}