const regex = /(?<=SECTION I\s?.+\s?\w*\s+\d.*\s+).+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=SECTION I\\s?.+\\s?\\w*\\s+\\d.*\\s+).+', 'gm')
const str = `SECTION I
Request Type Request Date Current Loginid
Deactivate 03/30/21 iamauserid
SECTION II More Stuff
Blah blah
SECTION III Even More Stuff
Blah blah blah
SECTION IV: So much stuff
Blah blah blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}