#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)P(.*\+)"
Local $sString = "Q-P-Q-Q" & @CRLF & _
"Q-P-Q+R-Q "
Local $sSubst = "C$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)