use strict;
my $str = 'Q-P-Q-Q
Q-P-Q+R-Q ';
my $regex = qr/P(.*\+)/mp;
my $subst = 'C$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";