const regex = /P(.*\+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('P(.*\\+)', 'gm')
const str = `Q-P-Q-Q
Q-P-Q+R-Q `;
const subst = `C$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);