import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/([a-zA-Z0-9_-]+)\\.(css|js)";
final String string = "duis ut diam quam /app.css porttitor\n"
+ "app.css\n"
+ "main.js\n"
+ "purus sit (amet volutpat /main.js)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}