re = /\/([a-zA-Z0-9_-]+)\.(css|js)/m
str = 'duis ut diam quam /app.css porttitor
app.css
main.js
purus sit (amet volutpat /main.js)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end