const regex = /\b(?=\d\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?=\\d\\b)', 'gm')
const str = `1.1.1998
10.1.1998`;
const subst = `0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);