$re = '/\b(?=\d\b)/m';
$str = '1.1.1998
10.1.1998';
$subst = "0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;