use strict;
my $str = '1.1.1998
10.1.1998';
my $regex = qr/\b(?=\d\b)/mp;
my $subst = '0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";