import Foundation
let pattern = #"\b(?=\d\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.1.1998
10.1.1998
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)