using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?!\bCats\h+Dogs\b)\b\w+\h+\w+\h+)*?(?:^\h*|\b(?!Cats\b)\w+\h+)(Dogs)\b";
string input = @"My Dogs are happy
Dogs are humans best friend
This is invalid Cats Dogs
The Dogs and Cats and Dogs and Dogs
There are Dogs and Cats and Dogs and Cats Dogs
The TomCats Dogs are valid
Dogs Cats Dogs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}