$re = '/(?:(?!\bCats\h+Dogs\b)\b\w+\h+\w+\h+)*?(?:^\h*|\b(?!Cats\b)\w+\h+)(Dogs)\b/m';
$str = 'My Dogs are happy
Dogs are humans best friend
This is invalid Cats Dogs
The Dogs and Cats and Dogs and Dogs
There are Dogs and Cats and Dogs and Cats Dogs
The TomCats Dogs are valid
Dogs Cats Dogs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);