import Foundation
let pattern = #"(?:(?!\bCats\h+Dogs\b)\b\w+\h+\w+\h+)*?(?:^\h*|\b(?!Cats\b)\w+\h+)(Dogs)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
My Dogs are happy
Dogs are humans best friend
This is invalid Cats Dogs
The Dogs and Cats and Dogs and Dogs
There are Dogs and Cats and Dogs and Cats Dogs
The TomCats Dogs are valid
Dogs Cats Dogs
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)