use strict;
my $str = 'My Dogs are happy
Dogs are humans best friend
This is invalid Cats Dogs
The Dogs and Cats and Dogs and Dogs
There are Dogs and Cats and Dogs and Cats Dogs
The TomCats Dogs are valid
Dogs Cats Dogs';
my $regex = qr/(?:(?!\bCats\h+Dogs\b)\b\w+\h+\w+\h+)*?(?:^\h*|\b(?!Cats\b)\w+\h+)(Dogs)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}