using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9-_+]+)(?:-([0-9.]+))([a-zA-Z])?((?:_(?:(?:alpha|beta|pre|rc|p)[a-zA-Z0-9]*))+)?(?:-r([0-9]+))?(?::([0-9.]+))?$";
string input = @"binutils:2.42
binutils-2:2.42
binutils-2.42:2.42";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}