package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z0-9-_+]+)(?:-([0-9.]+))([a-zA-Z])?((?:_(?:(?:alpha|beta|pre|rc|p)[a-zA-Z0-9]*))+)?(?:-r([0-9]+))?(?::([0-9.]+))?$`)
var str = `binutils:2.42
binutils-2:2.42
binutils-2.42:2.42`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}