import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z0-9-_+]+)(?:-([0-9.]+))([a-zA-Z])?((?:_(?:(?:alpha|beta|pre|rc|p)[a-zA-Z0-9]*))+)?(?:-r([0-9]+))?(?::([0-9.]+))?$";
final String string = "binutils:2.42\n"
+ "binutils-2:2.42\n"
+ "binutils-2.42:2.42";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}