const regex = new RegExp('^([a-zA-Z0-9-_+]+)(?:-([0-9.]+))([a-zA-Z])?((?:_(?:(?:alpha|beta|pre|rc|p)[a-zA-Z0-9]*))+)?(?:-r([0-9]+))?(?::([0-9.]+))?$', 'gm')
const str = `binutils:2.42
binutils-2:2.42
binutils-2.42:2.42`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}