import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!<h\\d>)(Lore.+?\\b)";
final String string = "<h2>Lorems ipsum dolor sit amet</h2>\n"
+ " <p>Loremi ipsum dolor sit amet</p>\n"
+ " <p>Loremis ipsum dolor sit amet</p>\n\n"
+ " <h3>Lorem ipsum dolor sit amet</h3>\n\n"
+ " <p>Lorem ipsum dolor sit amet</p>\n\n"
+ " <p>Lorem ipsum dolor sit amet</p>\n\n"
+ " <p>Lorem ipsum dolor sit amet</p><h4>Lorem ipsum dolor sit amet</h4><p>Lorem ipsum dolor sit amet</p><p>Lorem ipsum dolor sit amet</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}