re = /(?<!<h\d>)(Lore.+?\b)/i
str = '<h2>Lorems ipsum dolor sit amet</h2>
<p>Loremi ipsum dolor sit amet</p>
<p>Loremis ipsum dolor sit amet</p>
<h3>Lorem ipsum dolor sit amet</h3>
<p>Lorem ipsum dolor sit amet</p>
<p>Lorem ipsum dolor sit amet</p>
<p>Lorem ipsum dolor sit amet</p><h4>Lorem ipsum dolor sit amet</h4><p>Lorem ipsum dolor sit amet</p><p>Lorem ipsum dolor sit amet</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end