$re = '/(?<!<h\d>)(Lore.+?\b)/i';
$str = '<h2>Lorems ipsum dolor sit amet</h2>
<p>Loremi ipsum dolor sit amet</p>
<p>Loremis ipsum dolor sit amet</p>
<h3>Lorem ipsum dolor sit amet</h3>
<p>Lorem ipsum dolor sit amet</p>
<p>Lorem ipsum dolor sit amet</p>
<p>Lorem ipsum dolor sit amet</p><h4>Lorem ipsum dolor sit amet</h4><p>Lorem ipsum dolor sit amet</p><p>Lorem ipsum dolor sit amet</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);