import re
regex = re.compile(r"(?<!<h\d>)(Lore.+?\b)", flags=re.IGNORECASE)
test_str = ("<h2>Lorems ipsum dolor sit amet</h2>\n"
" <p>Loremi ipsum dolor sit amet</p>\n"
" <p>Loremis ipsum dolor sit amet</p>\n\n"
" <h3>Lorem ipsum dolor sit amet</h3>\n\n"
" <p>Lorem ipsum dolor sit amet</p>\n\n"
" <p>Lorem ipsum dolor sit amet</p>\n\n"
" <p>Lorem ipsum dolor sit amet</p><h4>Lorem ipsum dolor sit amet</h4><p>Lorem ipsum dolor sit amet</p><p>Lorem ipsum dolor sit amet</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")