#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z]\w+"
Local $sString = "str1 = '95% for Pikachu, 92% for Sandsherew'" & @CRLF & _
"str2 = '70% for Paras & 100% Arcanine'" & @CRLF & _
"str3 = '99% Diglett, 40% Dugtrio'" & @CRLF & _
"str4 = '10% Squirtle, 100% for Alakazam'" & @CRLF & _
"str5 = '30% Metopod & 99% Dewgong'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")