import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]\\w+";
final String string = "str1 = '95% for Pikachu, 92% for Sandsherew'\n"
+ "str2 = '70% for Paras & 100% Arcanine'\n"
+ "str3 = '99% Diglett, 40% Dugtrio'\n"
+ "str4 = '10% Squirtle, 100% for Alakazam'\n"
+ "str5 = '30% Metopod & 99% Dewgong'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}