re = /[A-Z]\w+/m
str = 'str1 = \'95% for Pikachu, 92% for Sandsherew\'
str2 = \'70% for Paras & 100% Arcanine\'
str3 = \'99% Diglett, 40% Dugtrio\'
str4 = \'10% Squirtle, 100% for Alakazam\'
str5 = \'30% Metopod & 99% Dewgong\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end