use strict;
my $str = 'str1 = \'95% for Pikachu, 92% for Sandsherew\'
str2 = \'70% for Paras & 100% Arcanine\'
str3 = \'99% Diglett, 40% Dugtrio\'
str4 = \'10% Squirtle, 100% for Alakazam\'
str5 = \'30% Metopod & 99% Dewgong\'';
my $regex = qr/[A-Z]\w+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}