#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?x)" & @CRLF & _
"^(-?([1-9]\d*[05])|-?5)$"
Local $sString = "5067" & @CRLF & _
"60" & @CRLF & _
"79" & @CRLF & _
"70" & @CRLF & _
"65" & @CRLF & _
"0" & @CRLF & _
"-5" & @CRLF & _
"-5670" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")