$re = '/(?x)
^(-?([1-9]\d*[05])|-?5)$/m';
$str = '5067
60
79
70
65
0
-5
-5670
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);