const regex = /(?x)
^(-?([1-9]\d*[05])|-?5)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x)
^(-?([1-9]\\d*[05])|-?5)$', 'gm')
const str = `5067
60
79
70
65
0
-5
-5670
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}