import re
regex = re.compile((r"(?x)\n"
r"^(-?([1-9]\d*[05])|-?5)$"), flags=re.MULTILINE)
test_str = ("5067\n"
"60\n"
"79\n"
"70\n"
"65\n"
"0\n"
"-5\n"
"-5670\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")