using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[\dB-Zb-zБ-Ьб-ь]{6,8}$)(?!.*[IUOEiuoeОИЕЁЫУоиеёыуiuoe])(\D*\d){3}.*";
string input = @"qww1q23";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}