re = /^(?=[\dB-Zb-zБ-Ьб-ь]{6,8}$)(?!.*[IUOEiuoeОИЕЁЫУоиеёыуiuoe])(\D*\d){3}.*/m
str = 'qww1q23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end