const regex = /^(?=[\dB-Zb-zБ-Ьб-ь]{6,8}$)(?!.*[IUOEiuoeОИЕЁЫУоиеёыуiuoe])(\D*\d){3}.*/gum;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[\\dB-Zb-zБ-Ьб-ь]{6,8}$)(?!.*[IUOEiuoeОИЕЁЫУоиеёыуiuoe])(\\D*\\d){3}.*', 'gum')
const str = `qww1q23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}