$re = '/^(?=[\dB-Zb-zБ-Ьб-ь]{6,8}$)(?!.*[IUOEiuoeОИЕЁЫУоиеёыуiuoe])(\D*\d){3}.*/um';
$str = 'qww1q23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);