package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\s@.]{0,25}[0-9]{3}@gmail\.com$`)
var str = `john.doe123@gmail.com
doe123@gmail.com
test12@gmail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}